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1. Introduction and Installation 
 

 

1.1. ZWCAD Introduction 

1.1.1. About ZWCAD and other CAD software 

ZWCAD is designed for anyone who wants a fast and efficient CAD program with all the 

power and versatility of standard programs such as AutoCAD® by Autodesk®, Inc., or 

MicroStation® by Bentley Systems, Inc., at an affordable price. Using todayôs advanced 

technology, ZWCAD integrates the Microsoft® Windows® interface with a powerful CAD 

engine. 

ZWCAD provides unparalleled compatibility with AutoCAD, using most of the same file 

formats including those for drawings (.dwg files), commands, linetypes, hatch patterns, 

and text styles. You can also use AutoCAD menu files and run Autodesk® AutoLISP® 

programs.  

ZWCAD is more compatible with the AutoCAD program than any other CAD product, 

delivers additional tools with advanced CAD features, and has a seamless Microsoft® 

Windows integration. This powerful program provides a superb combination of features for 

CAD users like architects, engineers, and designers. 

ZWCAD incorporates standard features found in other CAD programs, along with features 

and capabilities you wonôt find anywhere else. Its multiple document interface (MDI) lets 

you open and work with several drawings at the same time. You can easily copy drawing 

entities between drawings. 

Using AutoCAD legacy drawings 

ZWCAD fully supports AutoCAD legacy drawings. ZWCAD reads and writes DWG files in 

their native format without any loss of data, from AutoCAD 2009 back to Version 11, 

including AutoCAD LT®. Because ZWCAD uses DWG as its native file format, no 

translation is required. 

ZWCAD supports three-dimensional wireframes and surfaces. Three dimensional 

drawings can be displayed in wireframe, hidden line view, and surface shading. 

ZWCAD supports displaying and working with raster images in your drawings. When a 

drawing containing proxy entities is loaded into ZWCAD, a message displays indicating 

that some entities will not display. 

Itôs easy to customize ZWCAD. You can modify menus and toolbars, create custom 

menus, dialog boxes, command aliases, and scripts, and add custom programs written in 

any of several programming languages, including LISP and SDSÊ (Solutions 

Development SystemÊ, the programôs AutodeskÈ ADScompatible language). There is 

also Microsoft® Visual Basic for Applications (VBA). 

You can run existing LISP applications in ZWCAD with little or no modification. ZWCAD 

uses the Appload command so you can easily load LISP programs. 

ZWCAD reads files that contain dialog control language (DCL) statements as well, which 
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makes ZWCAD compatible with dialog boxes created for AutoCAD. 

Using AutoCAD commands with ZWCAD 

Because ZWCAD supports hundreds of AutoCAD commands, you use the commands 

you already know. For example, to draw a circle, use the Circle command. To copy a 

circle, use the Copy command. 

When you press Enter or the spacebar, you activate the commandðjust like in AutoCAD. 

ZWCAD accepts the special characters used by AutoCAD, such as point filters (for 

example, .xy), relative coordinates (the @ symbol), and the apostrophe (the ó prefix) for 

transparent commands. ZWCAD function keys are also similar to those used in 

AutoCAD.Because you do not need to learn a new set of commands, you are immediately 

productive with ZWCAD. 

1.1.2. Comparing ZWCAD drawing with manual drafting 

ZWCAD greatly reduces the time and effort it takes to create and revise drawings. Not 

only can you produce accurate drawings faster, you can also reuse the information in your 

drawings. 

These are the primary reasons for making the transition to CAD from traditional, manual 

drafting on paper. 

As with any tool, however, to use it effectively, you need to be familiar with some of the 

special features, functions, and concepts of CAD. If you are familiar with manual drafting, 

youôll find some conceptual similarities in CAD as well as some differences. 

Drawing to scale 

In traditional, manual drafting, you usually determine the scale of the drawing before you 

even start to draw, because you are working with a sheet of paper of a fixed size. You 

may have to reduce or enlarge the entity you are drawing to fit within the confines of the 

paper. 

When you create a drawing in ZWCAD, you draw everything full size. You determine the 

type of units in which your drawing is measured. If you are drawing a building, 1 drawing 

unit might equal 1 inch. If you are drawing a map, 1 drawing unit might equal 1 mile. Your 

drawing environment and the CAD drawing file itself are not limited to the size of a 

particular sheet of paper. 

 

1 drawing unit equals 1 inch.            1 drawing unit equals 1 foot. 
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As you draw, you can use commands such as Pan and Zoom to work on different part of 

the drawing and to magnify the display of the drawing to view small details. These 

commands have no effect on the actual size of the entities in your drawing; they affect 

only the way the drawing is displayed on your screen. Only when you print or plot your 

drawing do you need to set the scale so that the printed drawing fits within a specific paper 

size. 

Using tools 

In manual drafting, you use tools such as pencils, rulers, T squares, templates, erasers, 

and so on. When you create a drawing in ZWCAD, you use a mouse instead of a pencil, 

and you use the mouse to select other tools-commands you select from a menu or a 

toolbar. 

You use some tools to create basic entities, such as lines, circles, and arcs, and other 

tools to modify existing entities ( for example, to copy or move them or to change 

properties such as color and linetype). 

Organizing information 

In traditional drafting, you often separate elements such as walls, dimensions, structural 

steel members, and electrical plans onto separate, translucent overlays. When you want 

to print the working drawings, you can create several different drawings by combining 

different overlays. 

When you create a drawing in ZWCAD, you use layers to organize elements in a similar 

manner. 

However, the layers feature in CAD offers numerous advantages over physical 

transparencies. 

The number of overlays you can combine to print a manually drafted drawing is limited by 

the printing process. There is no such limitation in CAD. With ZWCAD, you can define an 

unlimited number of layers, any of which can be visible or invisible at any time. 

You can name each layer and assign each its own color, linetype, lineweight, and print 

style. 

You can also lock individual layers to ensure that information on those layers isnôt altered 

accidentally. 
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Use layers to organize drawing information. 

Drawing accurately 

When you create a manual drawing, ensuring accuracy typically requires a lot of manual 

calculations and rechecking. By contrast, ZWCAD offers a number of drawing aids that 

ensure accuracy from the start. For example, you create and modify entities based on an 

underlying Cartesian coordinate system. Every location in the drawing has its own x,y,z 

coordinates. You can also display a grid as a visual reference to your coordinate system. 

 

Each position in the CAD drawing has its corresponding x,y,z coordinates within Cartesian 

Coordinate System. Point 5,2,0 is 5 units to the right (along the x axis), 2 units up (along 

the y axis), and 0 units (alongthe z axis) from the origin (the 0,0,0 point) Settings such as 

snap and entity snap allow you to draw accurately without specifying coordinates. 

The snap setting forces the selected points to adhere to the grid increment or to any other 

increment you set. Entity snaps let you snap to precise geometric points on existing 

entitiesð for example, the endpoint of a line or the center of a circle. Another setting, 

orthogonal, constrains lines so that they are drawn parallel to the vertical and horizontal 

axes. Polar tracking and object snap tracking help you draw objects at specific angles or 

in specific relationships to other objects. When you turn on polar tracking and object snap 

tracking, temporary alignment paths help you create objects at precise positions and 

angles. You will discover techniques that make specific design tasks easier. 

 

Paper based drawings lack the high degree of accuracy possible when using CAD. Lines 
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often overlap or fail to meet adjacent lines. 

 

Snap and entity snap force the cursor to adhere to a specified increment or attach to key 

geometric points on existing entities. You can also constrain lines to vertical and 

horizontal axes. 

Drawing efficiently 

In paper based, manual drafting, you often have to redraw the same entity several times 

at different scales or from different vantage points. You may also need to redraw the 

border and title block on each new sheet. 

One of the most powerful features of ZWCAD is that when you create a drawing, you can 

reuse individual entities, borders, and title blocks as often as you want. You need draw an 

entity only once; the final printed drawing can show the entity at several different scales 

and viewpoints. 

You usually begin drawing in model space on the Model tab, creating the drawing (a floor 

plan, a map, or a three dimensional part) without regard to the final layout on paper. When 

you are ready to print your drawing, you have the option to switch to paper space on a 

Layout tab, where you lay out the drawing as you want it to appear on a sheet of paper. 

 

You create the basic drawing in model space on the Model tab. 
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When youôre ready to print or plot your drawing, you can switch to paper space on a 

Layout tab, where you provide a layout of the drawing as you want it to appear on a sheet 

of paper. 

Reusing CAD drawings and entities 

When you create a paper drawing manually, you can draw repetitive symbols by tracing a 

plastic template. After you draw a symbol in ZWCAD, you can reuse that symbol without 

having to redraw it. You simply save the symbol as a block. You can then insert copies of 

that block anywhere in your drawing. You can also save the symbol as a separate drawing 

for use in other drawings. 
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You can draw a symbol one time, save it as a block, and then insert multiple copies of that 

symbol anywhere in your drawing. 

In addition, you can reuse entire drawings and insert individual drawings into other 

drawings. 

You can also use an external reference, which acts as a pointer to another drawing rather 

than a copy of the entire drawing. Using an external reference has an added advantage: 

when you update the externally referenced drawing, each drawing that references it can 

be automatically updated. 

Making changes 

To make changes to a paper drawing, you erase and then redraw. With ZWCAD, you use 

commands to modify entities in the drawing. You can move, rotate, stretch, or change the 

scale of entities. When you want to remove an entity, you can delete it with a single click 

of the mouse. If you make a mistake while creating or modifying your drawing, you can 

easily reverse your actions. 
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You can easily change an entity using commands such as move, rotate, stretch, and scale 

instead of redrawing the entity. 

1.1.3. Working with other data and programs 

Traditional paper drawings serve only as a means of communicating information between 

the person who created the drawing and the person viewing the drawing. The drawings 

contain no more information than what is visually imparted by the creator and seen by the 

viewer. 

ZWCAD offers rich possibilities for analyzing drawings and attaching additional data to 

them. 

For instance, although it may be impractical to count entities in a complex paper drawing, 

this task is simple in CAD. ZWCAD can calculate the number of entities in a drawing and 

compute area and distance. 

CAD drawings can also contain information in addition to visible entities. You can attach 

invisible database information to visible drawing entities and extract the information for 

analysis in a database or spreadsheet. (Working with information in a data base requires 

a program from a third party vendor, or you can create your own means of exporting the 

data in LISP or SDS. Or, you can also use VBA.) 

 

You can extract information stored in the drawing as visible or invisible attributes and use 

that data for analysis in a database or spreadsheet. 

ZWCAD provides in-place editing of Microsoft® objects, such as those created in 

Microsoft® Word and Microsoft® Excel software programs. In place editing makes it easy 

to share data with other users and programs. For example, you can include ZWCAD 
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drawings in files created using Microsoft® Word, and you can insert files created using 

Microsoft® Word into your ZWCAD drawings. 

1.1.4. Using advanced CAD features 

In addition to being compatible with AutoCAD, ZWCAD goes several steps further by 

providing you with innovative features to increase your productivity. 

Editing multiple documents simultaneously 

With ZWCAD, you can open and edit multiple drawings simultaneously. You can also 

copy and paste elements among opened drawings. 

Editing multiple entities 

ZWCAD allows you to change most of the properties of all selected entities using a single, 

tabbed dialog box. 

Using the Customize dialog box 

ZWCAD has a single, tabbed dialog box for changing toolbars, menus, keyboard 

shortcuts, and command aliases. The simple, point and click action lets you easily create 

new menu items and keyboard shortcutsðno programming or manual text editing 

required. 

Performing unlimited undo and redo 

ZWCAD increases your power undo and redo of editing actions. 

1.1.5. Getting more information 

In addition to the ZWCAD documentation, much of the assistance you need as you use 

ZWCAD is specific to the commands you work with on the screen. To obtain immediate 

information as you work, use these additional sources of information: 

Status bar  

To find out more detailed information about a tool when you pause the cursor over it, look 

on the status bar at the bottom of the screen. 

Online help  

ZWCAD online help is available on the screen when you press F1, choose a command 

from the Help menu, or click the question mark in a dialog box.  

1.2. Installation 

This section helps you get started using ZWCAD software by explaining how to install it 

and providing basic information about how to use it. 

NOTE This guide assumes that you have used other Windows based programs and are 

familiar with Windows terminology and techniques. 

1.2.1. System requirements 

You need the following software and hardware to install and run ZWCAD: 

Operating system 

Microsoft Windows 2003̕Microsoft Windows XP 

Microsoft Windows Vista̕Microsoft Windows 7 

Processor 

Pentium III 800 Mhz or advanced 
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RAM 

512 MB (recommended) 

Video 

1024 x 768 VGA with True Color (minimum) 

Hard disk 

700 MB 

Pointing device 

Mouse, trackball or other device 

DVD-ROM 

Any speed (for installation only)  

1.2.2. Installing ZWCAD 

A setup program guides you through the ZWCAD installation process. The program 

transfers files to a folder that it creates on your hard disk. The program also creates a 

menu item on the Start menu. 

To install ZWCAD from a compact disc 

1. Insert the ZWCAD compact disc into your CD ROM drive. 

2. Double click the installation file of your desired software on the CD page. 

3. Follow the instructions of the installation prompts, choose from Standard Edition and 

Professional Edition to determine which one to install. 

NOTE If you did not receive an ZWCAD compact disc, for example, if you downloaded the 

program from the Internet, follow the instructions that came with the program. 
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2. The User Interface  
 

 

You can work with the ZWCAD window and its elements in a variety of ways. For example, 

you can display and rearrange the toolbars, display the command bar, and enable the 

status bar. 

The toolbars and command bar can also be floated anywhere on the screen or docked to 

the edges of the main ZWCAD window. You can customize the menu bar at the top of the 

window. 

You can customize the toolbars, changing the appearance and arrangement of tools and 

adding your own commands and macros. 

Your drawings are displayed in the drawing window. 

The user coordinate system (UCS) icon indicates the orientation of the drawing in two 

dimensional space (default setting). 

Click a tab to switch between the drawing of your model and a printed layout. 

You can type commands in the command bar. To reposition the command bar, drag it to 

another location on your screen. 

You can move and dock the toolbars to any location on your screen. 

Specialty editor. You can modify the value you wanted in each column. 

The status bar displays information such as the current cursor coordinates, and mode 

settings. 

2.1. MENUS and Shortcut Menus 

2.1.1. MENUS 

You can use any of the option on the Menus from the menu bar at the top of the ZWCAD 

drawing area. Choose one of the following methods to use a menu: 

 ̧ On the menu bar, click a menu name to display a list of options. To select a menu 

option, either click the option you want or use the DOWN ARROW to move down the 

list, and then press ENTER. 

 ̧ Press ALT and press the key for the underlined letter in the menu name; then, press 

the underlined letter in the option name. For example, to open a new drawing, press 

ALT and press F to open the File menu; then, press N for New.  

You can create a new menu with the path you specified (for example, a customized menu) 

in the Options dialog box, Files tab. 

2.1.2. Shortcut Menus 

Shortcut menus provide quick access to specific commands. A shortcut menu displays 

when you right click an object, toolbar, status bar, the Model tab name, or a Layout tab 

name. The selections presented in the shortcut menu depend on what you clicked. 

When you right click a toolbar, the program displays a shortcut menu that lets you toggle 

the command bar, status bar, and various toolbars on and off. If you select one or more 



CHAPTER 2   

12 
 

objects and then right click, the program displays a shortcut menu from which you can 

choose a command to modify the selected objects.  

To quickly access the relevant commands currently performed, you can right click on 

different area on the drawing window to display different shortcut menu, with the shortcut 

menu you can speed up the access. 

If you have entered commands or system variables, right click on the command line to 

perform the command or system variable automatically, without displaying the shortcut 

menu. 

To display a short cut menu from which you can choose an object snap and track, press 

and hold down the Shift key, and then right click anywhere within the drawing window. 

You can use +CUSTOMIZE command to customize the menus from the Customize dialog 

box. 

Recent Input 

ñRecent Inputò option is used for recording the recent manipulations, from the Recent 

Input list on right click menu, you can view the latest manipulations as well as the previous 

command options, and also manipulate commands by directly selecting from the recent 

input list. System variable INPUTHISTORYMODE is used for controlling its content, value 

from 0 to 15. If INPUTHISTORYMODE is set to 0, you cannot see the Recent Input option 

on right click menu, thus you can't view the latest input; if you set the 

INPUTHISTORYMODE to a value within 0-15, latest input records are displayed orderly. 

System variable CMDINPUTHISTORYMAX is used for controlling how many items to be 

displayed in the Recent Input menu option. You can set the value from 0 to 20, generally 

use the maximum as 20. Any value that is smaller than the maximum determines the 

number of items to be displayed on the right click menu. 

The contents displayed in the Recent Input menu option differs under various 

circumstances. For example, right click on the screen if there is no manipulation currently 

used, the latest commands ever manipulated will be displayed by the latest precedence 

orders. When right click in the process of a certain command, Recent Input displays items 

specific to the current manipulation such as coordinates, angle, length or relevant 

keyword. In case that current manipulation is not relative to any of the recent input, Recent 

Input option will not displayed on right click menu. 

2.2. Toolbars 

Toolbars partially contain buttons that start commands. When you move your mouse or 

pointing device over a toolbar button, the tooltip displays the name of the button. Buttons 

with a small black triangle in the lower-right corner are flyout icons of related commands. 

Hold down the left button on your mouse over the small black triangle icon until the flyout 

toolbar is displayed.  

The Standard toolbar at the top of the drawing area is similar to those found in Microsoft® 

Office programs. Which contains commonly used ZWCAD commands such as COPYȁ

PAN and ZOOM, as well as Microsoft Office standard commands such as New, Open, 

and Save. 

ZWCAD initially displays several toolbars by default:  
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 ̧ Standard toolbar 

 ̧ Styles toolbar 

 ̧ Layers toolbar 

 ̧ Properties toolbar  

 ̧ Draw toolbar 

 ̧ Modify toolbar 

You can display or hide these toolbars and additional ones. Use +CUSTOMIZE command, 

you can also create your own toolbars. 

You can move the floating command window anywhere on the screen and resize its width 

and height with the pointing device.Dock the command window by dragging it until it is 

over the top or bottom docking region of the ZWCAD window, but you canôt change its 

size. 

Displaying and hiding toolbars 

When you start ZWCAD the first time, multiple toolbars are displayed. ZWCAD provides 

more than a dozen toolbars, which you can customize by adding and deleting tools. You 

can also move and resize toolbars, and you can create new toolbars. You can use a 

shortcut menu to display or hide toolbars. 

You can also choose whether toolbars are displayed large or small and in color. You can 

choose to display or hide ToolTips, which provide descriptions of tools that display when 

you pause the cursor over them. Go to View > Toolbars to make these selections. 

Toolbars are either docked or floating. A floating toolbar has a title bar and a Close box, 

can be located anywhere on the screen, and can be resized. A docked toolbar does not 

display a title or Close box, cannot be resized, and is attached along one of the edges of 

the drawing window. 

To choose which toolbars to display 

1 Choose View > Toolbars. 

2 In the Select Toolbars dialog box, choose the toolbars you want displayed, and then 

click OK. 

TIP Right click anywhere on a docked toolbar to display the toolbar shortcut menu, and 

then choose Toolbars.  

Starting commands using toolbars 

To start a command from a toolbar, click a tool and respond to the prompts. 

NOTE The available toolbars depend on the experience level that is set. To change the 

current experience level, choose Tools > Options, and then click the Open and Save tab. 

2.3. The Command Window 

The command bar is a dockable window in which you type ZWCAD commands and view 

prompts and other program messages. To display the command bar, choose 

View >Display>Command Bar. You can move the command bar by dragging it. 

When the command bar is floating, you can drag the top or bottom of the window to 

change the number of lines of text it displays. You can dock the command bar at the top or 

bottom of the drawing. 

2.3.1. Enter Commands or System variables 
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Type a command or system variable by using the keyboard. System variables are such 

parameters that are available for controlling how certain commands work. 

Enter Commands on the Command Line  

Type the full command name on the command line and press ENTER or SPACEBAR, or 

right-click your pointing device to start the command. 

Some commands also have abbreviated names. Abbreviated command names are called 

command aliases. To define your own command aliases, you can customize from Aliases 

tab on the Customize dialog through performing CUSTOMIZE command. 

Specify Command Options  

Once you have entered commands on the command line, ZWCAD displays either a set of 

options or a dialog box. To choose a different option, enter the one of the options in the 

brackets, either uppercase or lowercase letters is OK. 

Execute Commands  

To execute commands, press SPACEBAR or ENTER, or right-click your pointing device 

when the command names has been entered or responseded to prompts.  

Repeat and Cancel Commands  

If you want to repeat a command that you have just used, press ENTER or SPACEBAR.  

To cancel a command in progress, press ESC. 

To repeat the command you just used 

Do one of the following: 

 ̧ Press the spacebar. 

 ̧ Press Enter. 

 ̧ Click the right mouse button in the drawing. 

Nesting a command 

If you are working in the command bar, you can use another command from within a 

command, called nesting. To use a command inside an active command, type an 

apostrophe before you type the command, such as ócircle, óline, or ópyramid. You can nest 

commands indefinitely in ZWCAD. Many menu and toolbar macros work this way by 

default; for example, select color, reference grid, zoom, and snap. When you have 

finished with the nested command, the original command resumes. 

For example, you turn on the object snap while you are drawing a circle, thus you can 

setup Object snap mode before continuing drawing. 

Command: circle 

2Point/3Point/Ttr(tan tan radius)/Arc/Multiple/&lt;Center of circle&gt;: 'osnap 

( Setup object snap mode as Center in Draft Settings dialog, and then close the dialog to 

go on performing CIRCLE command ) 

2Point/3Point/Ttr(tan tan radius)/Arc/Multiple/&lt;Center of circle&gt;: 

Enter System Variables on the Command Line 

System variables are available for controlling how certain commands work. For example, 

GRIDMODE is used to control the status ON or OFF for ñSNAPò,òGRIDòoròORTHOòmode, 

Sometimes you use a system variable in order to change a setting. System variable can 

be used to display the current status as well.  

ms-its:ZWCAD_ICR.chm::/CUSTOMIZE.htm
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While using another command; you can examine or change a system variable's setting 

transparently, however, new values may not take effect until the interrupted command 

ends.  

2.3.2. Edit Within the Command Window 

Navigate and Edit Within the Command Window  

The standard keys below are provided for navigating and editting text in the command 

window to correct or repeat commands. 

 ̧ UP, DOWN, LEFT ARROW and RIGHT ARROW 

 ̧ INS, DEL 

 ̧ PAGE UP, PAGE DOWN 

 ̧ HOME, END 

 ̧ BACKSPACE 

Use UP ARROW, DOWN ARROW and ENTER, you can repeat any command used in the 

current session by cycling through the commands in the command window. 

By default, pressing CTRL+C copies highlighted text to the Clipboard. Pressing CTRL+V 

pastes text from the Clipboard to the text window or the command window.  

If you right-click on the command window or text window, ZWCAD displays a shortcut 

menu from which you can copy selected text or the entire command history, paste text, 

and access the Options dialog box of the Command window.  

In general, a command line with two or three lines of previous prompts is given to several 

commands, called the command history, which is sufficient for viewing and editing. To see 

more than one line of command history, you can scroll through the history or resize the 

command window by dragging its border upwards, or you can press F2 to use the text 

window. 

The text window is a window similar to the command window in which you can enter 

commands and view prompts and messages. With a complete command history for the 

current ZWCAD session displayed, the text window can be used to view lengthy output of 

commands such as LIST, which displays detailed information about objects you select. 

To copy all the text in the text window to the Clipboard, use the COPYHIST command. 

Dock and Resize the Command Window  

By default, the command window is docked. The docked command window is the same 

width as the ZWCAD window. 

You can resize the window vertically by dragging the splitter bar, which is located on the 

top edge of the window when it is docked on the bottom and at the bottom edge of the 

window when it is docked at the top.  

Undock the command window by dragging it away from the docking region. When you 

undock the window, the floating window is the size it was before you undocked it. You can 

move the floating command window anywhere on the screen and resize its width and 

height with the pointing device. 

Dock the command window by dragging it until it is over the top or bottom docking region 

of the ZWCAD window. 

Modifying a command 
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If you are working in the command bar, there are special ways that you can modify a 

command as you work. You can modify the active command using any of the following 

options: 

 ̧ Object snaps ð Type an object snap command, such as nearest or midpoint, to 

enable a one time object snap for a single selection. You can also use a one time 

object snap to override a running object snap. 

 ̧ Extension snaps ð Type int after selecting a command, such as Line or Circle, to 

enable a one-time snap to the logical location where two objects would intersect if 

they were of infinite length. Type app to enable a similar one time snap if the 

extensions would not intersect in three dimensional space but would intersect in the 

current view. 

Using the Prompt History window 

The Prompt History window displays a history of the commands and prompts issued since 

you started the current session of ZWCAD. By default, the program tracks up to 256 

command lines. 

There is no limit to the number of command lines you can track, but program performance 

may be degraded if you choose to track an excessively high number of lines. 

To display or close the Prompt History window 

 ̧ Press F2. 

To view entries in the Prompt History window 

Do one of the following: 

 ̧ Use the scroll bars. 

 ̧ Use the Up and Down arrows to display previously used commands. 

To copy or paste text in the Prompt History window 

1 If you want to copy text from the text window, do one of the following to get the text field 

that you want: 

 ̧ Highlight text using your mouse. 

 ̧ Press Ctrl + Shift + arrow keys to highlight text. 

2 Right-click and choose whether to copy or paste. 

TIP You can also copy the entire command history by choosing Copy History. 

2.3.3. Switch between Dialog Boxes and the Command line  

Some functions are both provided similarly though the command line and from a dialog 

box. In many cases, you can enter a hyphen in front of the command to suppress the 

dialog box and display prompts on the command line instead.  

For example, entering linetype on the command line displays the linetype Manager. 

Entering -linetype on the command line displays the equivalent command line options. 

There may be tiny differences between the options in the dialog box and those available 

on the command line. 

The system variables below affect the display of dialog boxes as well: 

 ̧ ATTDIA controls whether INSERT uses a dialog box for attribute value entry. 

 ̧ EXPERT controls whether certain warning dialog boxes are displayed.  

 ̧ FILEDIA controls the display of dialog boxes used with commands that read and 

write files. For example, if FILEDIA is set to 1, OPEN displays the Open Drawing 
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As dialog box. If FILEDIA is set to 0, OPEN displays prompts on the command 

line. Even when you set FILEDIA to 0, you can get a file dialog box displayed 

through entering a tilde (~) at the first prompt.  

2.4. Dynamic input 

"Dynamic input" box is a floating window which appears near the cross cursor in the 

implementation of any drawing command, it provides a convenient method for users to 

input command prompt dynamically instead of using command window. When the DYN 

mode is turned on, a floating window will appear near the cross cursor displaying 

command line prompt and changing along with the cursor moves. "Dynamic input" box 

displays the identical contents as the command line shows synchronously whereas 

unavailable if DYN mode is off.  

"Dynamic input" box facilitates users to draw pictures freely and efficiently, which is 

comparatively more intuitionist than using command window to display prompts when 

executing a drawing command. 

"Dynamic input" box can not replace command window, you can press F12 to hide 

command window to increase drawing area, but it is sometimes necessary when 

implementing certain commands. 

Status of Dynamic input 

Clicks on the ñDYNò button on status bar to control its status. When "Dynamic input" mode 

is turned on, the command line prompt will be displayed in the "Dynamic input" box 

synchronously; while the "Dynamic input" mode is turned off, the toolbar box displays 

current polar coordinate of cross cursor. 

DYN ON 

Turns on the ñDYNò mode on states bar, the prompt box near the cross cursor will 

dynamically display command line prompt, users can input command options according to 

command prompt displayed in the "Dynamic input" box to execute drawing command. 

With DYN mode on, you can temporarily ignore command window, so as to make you 

concentrate on drawing area when drawing pictures. Press F2 to view prompt history of 

command window.Tooltips show as follows when DYN mode off status (take circle 

drawing for example): 

 

DYN OFF 

When executing command with the DYN mode off, there isn't any dynamic prompt near 

the cross cursor, you have to view the relevant prompts from command line or command 

window  

2.5. Customize the Drawing Environment 

2.5.1. Set Interface Options 
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In the Options dialog box, you can change many of the settings that affect the ZWCAD 

interface and drawing environment. 

Settings of modifying interface: 

 ̧ Automatic Save (Open and Save tab). Saves your drawing at specified time 

intervals. To use this option, in the Options dialog box, Open and Save tab, select 

Automatic Save and enter the interval in minutes. 

 ̧ Color (Display tab). Specifies the background colors used in the layout and Model 

tabs and the color used for prompts and crosshairs.  

 ̧ Font (Display tab). Changes the fonts used in the ZWCAD window and in the text 

window. This setting does not affect the text in your drawings.  

 ̧ Search Path (Files tab). Sets the search path ZWCAD uses to find drawing 

support files such as text fonts, drawings, linetypes, and hatch patterns.  

 ̧ Interface color( ñSkins and Themesòtab). Sets ZWCAD window skins and display 

themes. 

Controlling size and position of each toolbar or window: 

After starting ZWCAD, you can fix or adjust position and size of each toolbar or window by 

dragging. Software interface includes column, order window, "Properties" option board, 

"Quick Calculator" window, "Design Center" window, and so on.  

Controlling position of toolbar 

Toolbars can be floating or fixed. The floating toolbar locates in arbitrary location of the 

drawing area of ZWCAD window, can be dragged to its new location, adjust its size or 

fixed. Fixed toolbar attaches to any of the edges in drawing area, once the toolbar is fixed, 

its size canôt be adjusted. You can remove the fixed toolbar by dragging it to a new fixing 

position.  

Controlling size and position of other windows 

When dragging command window, "Properties" option board, "Quick Calculator" window, 

buoys displayed in corners and center position of drawing area, if not select buoys but 

dragging the selected window to arbitrary position of drawing area, the window will be on 

floating state, users can adjust size of the window based on the actual needs. If Click on 

the one of the buoys in the process of dragging, the location of the window will be fixed to 

the top, bottom and left side or right side of a fixed region of ZWCAD window, at this time, 

the size of window can be adjusted in only one direction.  

Locks the position of toolbars and docked windows 

For aligned toolbars and docked, floating windows, you can lock their position. Locked 

toolbars or windows can still be opened or closed and items can be added and deleted, 

but can not be moved. If need to unlock temporarily, you can press down CTRL.  

Displaying commands on a shortcut menu 

Shortcut menus provide quick access to specific commands. A shortcut menu displays 

when you right click an object, toolbar, status bar, the Model tab name, or a Layout tab 

name. The selections presented in the shortcut menu depend on what you clicked. 

When you right click a toolbar, the program displays a shortcut menu that lets you toggle 

the command bar, status bar, and various toolbars on and off. If you select one or more 
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objects and then right click, the program displays a shortcut menu from which you can 

choose a command to modify the selected objects. To display a short cut menu from 

which you can choose an object snap, press and hold down the Shift key, and then right 

click anywhere within the drawing window. 

Using the command bar 

The command bar is a dockable window in which you type ZWCAD commands and view 

prompts and other program messages. To display the command bar, choose 

View >Display> Command Bar. You can move the command bar by way of dragging. 

When the command bar is floating, you can drag the top or bottom of the window to 

change the number of lines of text it displays. You can dock the command bar at the top or 

bottom of the drawing. 

Using the status bar 

If you elect not to use the command bar, the status bar displays information about the 

selected command or tool. It also displays the current cursor coordinates, mode settings, 

and other information about current settings. 

In addition to displaying information, the status bar is a quick way to access many 

features. 

You can click status bar items to make changes, and right click items to display short cut 

menus that allow you more choices. 

 
A Cursor coordinates (x,y,z). 

B Snap setting. Left click to toggle on or off. toggle on or off. 

C Grid setting. Left click to toggle on or off. 

D Orthogonal setting. Left click to toggle on or off 

E Polar tracking. Left click to change colors. 

F Object snap setting. Left click to select object snaps on or off. 

G Object snap tracking. Left click to toggle on or off. 

H Lineweight display. Left click to toggle on or off. 

I Model space or paper space. Left click to toggle between model space and paper space. 

J Digitizer mode. Left click to toggle on or off. 

K Dynamic input. Left click to toggle on or off.  

To change the items that display on the status bar 

1 Right click an empty area of the status bar. 

2 Select an item to add or remove it. 

To change the setting of an item on the status bar 

Right click the status bar item you want to change, and then select the desired setting. 

To display or hide the status bar 

Choose View >Display> Status Bar. 

Command line STATBAR 

Using prompt boxes 
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ZWCAD commands often provide several options. These options appear in the status bar 

or command bar and also in a prompt box (called a context men) initially displayed in the 

upper right corner of the screen.  

You can move the prompt box by dragging it; future prompt boxes will appear where you 

last placed it. The options appear as menu selections.  

Choose the appropriate option by selecting it in the prompt box. To close a prompt box, 

click the Close box. 

 

Command options appear in a prompt box. 

The prompt box is closed by default. To turn on the display of prompt boxes, choose 

Tools > Options, click the Display tab, and then click the Display screen menu check box 

to clear it. 

2.5.2. Save and Restore Profiles 

Creating profiles for different users or projects and sharing profiles by importing and 

exporting profile files are enabled in ZWCAD.  

By default, your current options are stored in a profile named Default.The current profile 

name, as well as the current drawing name, are displayed in the Options dialog box in 

ZWCAD. 

ZWCAD stores the profile information in the system registry and saves it as a text file (an 

ARG file). ZWCAD also organizes essential data and maintains changes in the registry as 

required. 

If you make changes to your current profile during an ZWCAD session and you want to 

save those changes in the ARG file, you must export the profile. When you export the 

profile with the current profile name, ZWCAD updates the ARG file with the new settings. 

You can re-import the profile into ZWCAD to update your profile settings. 

2.6. Tool Palettes 

Tool Palettes provide an efficient tool that is used to organize, share, and place command, 

block as well as other tools. With Tool Palettes, you can organize blocks and commands 

in a window in order to use them efficiently. 

You can configure tool palettes with the shortcut menus by right-clicking the mouse on the 

different areas of the Tool Palettes window. For example, with the shortcut menu, you can 

add, rename, or remove tool palettes, as well as copying a tool on the current tool palette 

to another palette. 

The objects that are created using a tool from the Tool Palettes have the same properties 

as the objects you create from the menu or toolbar. To run a command, click the desired 

tool on the Tool Palette. For example, you can create a line by clicking the line tool. 
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When you click an arrow next to a tool, all other tools that have the similar properties are 

displayed. The objects that are created using a tool on a tool flyout have the same 

properties as the objects you created from the original tool.  

You can create a block tool by dragging a block out of an exterior file to the current tool 

palette performed from the Design Center. The items to be added to a tool palette are 

called Tool. By clicking the block tool, you can insert the block into your current drawing. 

ZWCAD supports using existing entities as tools via adding the entity to the tool palettes. 

You can firstly select the entity to be used as tool from the drawing area, select Copy from 

right click menu, and then right click on anyone of the palettes or current palette, select 

Paste option, thus a tool is created. Currently supported entities are arc, defined attributes, 

circle, ellipse, line, 2D and 3D polyline, mline, mtext, point, 3Dmesh, ray, region, 2Dsolid, 

spline curve, text, tolerance, trace, construction line wipeout and so on. 

Once you have added geometric entities (circle, line, polyline .etc) to a tool palette by way 

of copy and paste, a new tool list with flyout will be automatically generated on the 

palettes. For example, a triangle will be displayed on the new geometric entity icon, click 

this triangle to flyout tool list containing lines, construction line, polyline and circle .etc. 

The changes made to the Tool Palettes are saved as a configuration file automatically, 

which are still available when you launch ZWCAD again. 
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3. Create and Save a Drawing 
 

 

3.1. Create a new drawing 

When the system variables FILEDIA and STARTUP are set to 1, typing NEW opens 

Startup dialog box, from which, you can use Default Setting, Template or Wizard to create 

a new drawing. 

When the FILEDIA and STARTUP are set to 1 and 0 separately, typing NEW opens Open 

Template dialog box, from which you can select the desired one or use the default 

template by clicking arrowhead button next to Open button. 

Typing QNEW creates a new drawing with a default template. No dialog box is displayed 

with this command. 

You can change the search path of template files from the FILE tab in the Options dialog 

box. 

3.1.1. Start a Drawing from Scratch 

You can select either imperial or metric units for the new drawing if you choose Start from 

Scratch. The setting you select determines default values which is used for many system 

variables controlling text, dimensions, grid, snap, and the default linetype and hatch 

pattern file. 

 ̧ Imperial. A new drawing with the imperial measurement system. The drawing 

uses internal default values, and the default boundary is 12 × 9 inches.  

 ̧ Metric. A new drawing with the metric measurement system. The drawing uses 

internal default values, and the default boundary is 429 × 297 millimeters.  

When you start ZWCAD, there are three options for choosing to draw. You can start from 

scratch using default settings, you can start from a template file with a preset environment, 

or you can use a wizard to step you through the process, in each case, you can choose 

the conventions and defaults you want to use. 

Start a Drawing from Scratch 

You can start from scratch to create a new drawing quickly by using settings from a 

default drawing template file. 

To start a drawing from scratch with the Startup dialog box. 

1 On the File menu, click New. 

2 In the Startup dialog box, click Start from Scratch. 

3 Under Default Settings, click either Imperial or Metric. 

Standard toolbar  

Command line NEW 

3.1.2. Use a Setup Wizard 
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From the Startup dialog box, you can select ñUse a Wizardò tab to create a new drawing 

by the wizard. There are two wizard options illuminated as follows: 

Advanced Setup Wizard 

From this option, you can set units of measurement, precision of displayed units, and grid 

limits. Also specify angle settings such as units of measurement style, precision, direction, 

and orientation based on template ZWCADiso.dwt. 

Quick Setup Wizard 

From this option, you can specify units of measurement, precision of displayed units, and 

grid limits based on template ZWCADiso.dwt. 

To begin a new drawing using a wizard 

1 On the File menu, click New. 

2 In the Startup dialog box, click Use a Wizard. 

3 Click Quick Setup or Advanced Setup. 

4 Complete the wizard pages using the Next and Back buttons to move forward and 

backward. 

5 On the last page, click Finish. 

Standard toolbar  

Command line NEW 

3.1.3. Use a Template File to Start a Drawing 

Drawing template files contain standard settings and have a .dwt file extension. 

There are two methods provided for creating a new drawing when the system variable 

FILEDIA is set to 1. 

 ̧ When the STARTUP is set to 1, typing NEW opens Startup dialog box, from which, 

you can select the desired template to create a new drawing. 

 ̧ When the STARTUP is set to 1, typing NEW opens Open Template dialog box, from 

which, you can select the desired template to create a new drawing. 

The changes made to a new drawing based on an existing template file do not affect the 

template file. 

Create a Drawing Template File 

When you need to create several drawings with the default settings, you can save time by 

creating a template file designed to create the same drawing files so that you does not 

need to specify default settings each time you start. Conventions and settings commonly 

stored in template files include: 

 ̧ Unit type and precision 

 ̧ Title blocks, borders, and logos  

 ̧ Layer names  

 ̧ Snap, Grid, and Ortho settings  

 ̧ Grid limits  

 ̧ Dimension styles  

 ̧ Text styles  

 ̧ Linetypes 
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Recover the default drawing template file 

If you have changed the settings in the template file ZWCAD.dwt or ZWCADiso.dwt, you 

can reset them by creating a new drawing with no template and then saving the drawing 

as a drawing template file in order to replace ZWCAD.dwt or ZWCADiso.dwt. 

When the STARTUP is set to 0, you can also create a new drawing with the original 

defaults by clicking the arrowhead next to Open button to select one of the No Template 

options from the Open Template dialog box. 

To start a drawing by selecting a template file 

1 On the File menu, click New. 

2 In the Select Template dialog box, select a template from the list and click Open. 

ZWCAD opens the drawing as drawing1.dwg. The default drawing name changes to 

reflect the number of new drawings that have been opened. For example, if you open 

another drawing from a template, the default drawing name is drawing2.dwg. If you want 

to start a new drawing with no template file, click the arrow next to the Open button and 

then click one of the ñno templateò options from the list. 

Standard toolbar  

Command line NEW 

3.2. Open an Existing Drawing 

You can open drawing (.dwg) files, Drawing Exchange Format (.dxf) files, Design Web 

FormatÊ (.dwf) files, and drawing template (.dwt) files. 

You can also open and check drawings that you suspect are damaged. 

To open an existing drawing 

1 Choose File > Open. 

2 In Files of Type, choose the type of file you want to open. 

3 Choose the folder containing the desired file. 

4 Do one of the following: 

 ̧ Choose the drawing you want to open, and then click Open. 

 ̧ Double click the drawing you want to open. 

 ̧ If the drawing requires a password, enter the password, click OK to verify the 

password, and then click Open again. 

Standard toolbar  

Command line OPEN 

TIP You can also open drawings while browsing files on your computer using programs 

that came with your operating system, such as Windows File Explorer or My Computer. 

Just double click the file to get it open in ZWCAD. Easily find the drawing you want by 

viewing thumbnail images of the drawing files as you browse them. 

TIP To quickly open a drawing file that you recently used, choose File > <file name>. The 

File menu tracks the latest four drawings by default. 

3.2.1. Find and open a Drawing File 
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You can search for a drawing using name, location, and date filters or properties such as 

keywords that you added to the drawing.  

Open drawing 

Uses Open on the File menu or Quick Access toolbar to open Select File dialog box, from 

which you can select the desired file. 

You can also open a drawing by dragging a drawing into anywhere outside the drawing 

area. However, if you drag a drawing into the drawing area of an open drawing, the new 

drawing is inserted into the open drawing as a block reference instead of opening it. 

You can also double-click drawing to launch ZWCAD program to open it. If ZWCAD is 

running, the drawing opens in the current session. 

Change the default drawing folder 

Each time you launch ZWCAD, the path you specified to open a latest drawing is 

displayed in each standard file selection dialog box. You can also specify a default path to 

ZWCAD by changing default drawing folder. 

Find a drawing file 

Clicking Tools button from the Open Drawing dialog box displays Search dialog box, from 

which, you can search drawing through name, location and date filters. 

You can preview the selected drawing in the Open Drawing dialog box. When the system 

variable RASTERPREVIEW is on, a preview image with BMP format is generated and 

saved with the drawing. 

Set the search path 

The Files tab of Options dialog box is used by ZWCAD to search drawing support files. 

The support files includes text fonts, drawings, linetypes and hatch patterns. 

The system variable MYDOCUMENTSPREFIX is designed to store the location of My 

Documents folder for the current user. 

You can also specify the location of temporary files on the Files tab of the Option dialog 

box. Temporary files are created on the specified path and then deleted when you exit 

ZWCAD program. The default temporary folder is specified to the location that Microsoft 

Windows uses.  

You should specify another location for temporary files when you run ZWCAD in a 

write-protected director for example, if you work on a network or open files on a CD). The 

director must not be write-protected and can provide enough disk space for the temporary 

files. 

Add identifying information to drawings 

You can find the specified drawings more easily by adding keywords or other information 

to them in the Drawing Properties dialog box opened from the File menu. The drawing 

properties such as title, author, subject, keyword or other important information can help 

identify drawings more easily. You can also assign hyperlink addresses, director paths 

and multiple custom properties to your drawings. 

The Drawing Properties dialog box contains the following drawing information: 

 ̧ General. It contains the drawing type, location, size and other information. These 

information are stored by the operation system and can be read-only. You can change 

these values only through Windows Explorer. 
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 ̧ Summary. This tap contains the drawing properties such as author, title and subject. 

 ̧ Statistics. The drawing size, created date and latest modified date and other 

information are displayed in this tap. 

 ̧ Custom. Specifies the custom file properties.  

3.2.2. Work with Multiple Open Drawings 

You can open multiple drawings at one time. There are several methods for switching a 

drawing to another. 

 ̧ Acting the drawing by clicking it 

 ̧ Uses shortcut keys of CTRL+6 or CTRL+TAB. This option is not available while 

ZWCAD is running other command. 

 ̧ You can change the display styles to Cascade, Title Vertically or Title Horizontally 

from the Window menu. You can also use Arrange Icons to align icons if there are 

several minimum drawings.  

You can quickly reference other drawings to copy and paste between drawings. You can 

also use Match command to copy properties from objects in one drawing to objects in 

another drawing. Object snaps, the Copy with Basepoint  ( COPYBASE ) command, and 

the Paste to Original Coordinates ( PASTEORIG) command is used to ensure accurate 

placement, especially when copying objects from one drawing to another. 

3.2.3. Recover a Damaged File 

You can recover some or all of data by reverting to a backup file or using commands to 

find and correct errors if a drawing file is damaged. A drawing file may be damaged by a 

hardware failure, power outage and system crash. You can minimize loss by saving files 

frequently. 

ZWCAD can recover a slightly damaged drawing file while opening it. 

If a drawing is damaged, you can use RECOVER command to check and attempt to open 

it. Then uses AUDIT command to find and correct errors. 

Though ZWCAD can recover a damaged drawing file, it is not sure that the recovery 

drawing is the same exactly as the original one. You had better create a backup file if the 

drawing is important. On the Open and Save tap of Options dialog box, you can specify 

the backup file are created when you save drawings and set the proper interval time for 

saving. Then a backup copy file with a .bak extension is created when you save the 

named drawing once again. After that, a backup file is always updated while you 

executing the command SAVE or SAVEAS. 

If ZWCAD exits unexpectedly, it attempts to rename the current backup file in order to 

avoid covering the original one.   

You can recover a drawing file by saving a bak file to a dwg file.  

Files can become damaged for many reasons. For example, if you are working on a 

drawing during a power outage, a system crash, or a hardware failure, your drawing file 

may become damaged. ZWCAD allows you to open and check damaged files to attempt 

file recovery. 

Recovering a file attempts to open one of the following file types: 

 ̧ Standard drawing files with a .dwg extension. 

ms-its:ZWCAD_ICR.chm::/COPYBASE.htm
ms-its:ZWCAD_ICR.chm::/PASTEORIG.htm
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 ̧ Drawing Exchange Format files with a .dxf file extension. 

 ̧ Design Web Format files with a .dwf file extension. 

 ̧ Drawing templates with a .dwt file extension. 

You can also audit any open file to check it for errors. You specify whether you want 

ZWCAD to fix any errors that are found automatically. ZWCAD fixes as many errors as 

possible and any errors that cannot be fixed are reported as ñIgnoredò in the Prompt 

History window. 

To open a damaged file 

1 Choose File > Drawing Utilities>Recover. 

2 In Files of Type, choose the type of file you want to recover. 

3 Choose the directory containing the damaged file. 

4 Choose the damaged file you want to recover. 

5 Click Open. 

Command line RECOVER 

To check errors for a drawing file 

1. With the drawing open that you want to check, choose File > Drawing Utilities > Audit. 

2. Input Y or N to determine whether to recover the errors that are automatically found by 

ZWCAD, and then press Enter. 

Command line AUDIT 

Drawing Recovery 

Once terminated by hardware problems, power failure or software problems, the 

application is capable of backup the opened drawing file. At the next startup, the program 

starts ñDrawing Recoveryò manager in which all of the auto-backup drawing files that have 

been closed accidentally will be displayed. You can open the file of your demand by 

double clicking at the Backup File list on the ñDrawing Recoveryò, if there is any damage 

to the file, system attempts to recover the drawing in process of backup. 

When program or system stopped by accident, the drawing files need to recover are 

sorted into the following types: 

 ̧ Recovered drawing file saved when program fails.( DWG ) 

 ̧ Auto saved file, so called ñauto-saveò file (SV$) 

 ̧ Backup file (BAK) 

 ̧ Source drawing file ( DWG )  

3.3. Save a Drawing 

You save drawing files for later use just as you do with other Microsoft Windows 

applications. You can also set up automatic saving and backup files and save only 

selected objects. 

The file extension for drawing files is .dwg, and unless you change the default file format 

in which drawings are saved, drawings are saved in the latest drawing-file format.  

After you have saved your drawing for the first time, you can save it with a new name. In 

addition to drawing (.dwg) files, you can also save a drawing in a Drawing Exchange 

Format (.dxf) file or a drawing template (.dwt) file. 

If you created your drawing using a template, saving the drawing does not alter the 
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original template. 

To save a drawing: 

Choose File > Save. 

Command line SAVE 

TIP When you save a drawing the first time, the program displays the Save Drawing As 

dialog box so that you can choose a directory and type a name for the drawing. 

Save Your Drawing Automatically 

You can specify to save drawing files automatically in order to minimize the lost data once 

a problem occurs. 

If you start the automatic save option, your drawing is saved at specified time intervals. By 

default, system assigned the name filename.sv$ for temporarily saved files, filename here 

refers to current drawing name. 

The temporary files are removed automatically when a drawing closes normally. However, 

these files are not deleted if there is a program failure or power failure. You can recover 

the drawing by reverting to a previous version of your drawing from the automatically 

saved file. In order to do that, you have to rename the file using a .dwg extension. 

Use Backup Files 

ZWCAD creates a backup file with the current drawing name and a .bak extension to save 

the previous version of the current drawing when launching ñbackup automaticallyò option. 

You can revert to the previous version of your drawing anytime using a .dwg extension in 

place of the .sv$ extension. 

Save Part of a Drawing File 

You can use BLOCK command or WBLOCK command to create a new drawing from part 

of an existing drawing. You can select entities or a block definition in your current drawing 

and save them in a new drawing file. The description also can be saved in the new 

drawing. 

Save to a Different Type of Drawing File 

Choose the format from Files of Type in the Save Drawing As dialog box, you can save a 

drawing to an earlier version of the drawing format (DWG) or drawing interchange format 

(DXF), or save a drawing as a template file. 

You can save a drawing with a new name and in any of the following file formats: 

 ̧ Standard drawing files with a .dwg extension. You can choose a .dwg file format that 

is compatible with various versions of AutoCAD. 

 ̧ Drawing Exchange Format files with a .dxf file extension. You can choose a .dxf file 

format that is compatible with various versions of AutoCAD. 

 ̧ Drawing templates with a .dwt file extension. Drawing templates allow you to easily 

create new drawings that reuse your drawing settings and entities. 

To save a drawing with a new name or file format 

1 Choose File > Save As. 

2 In the Save Drawing As dialog box, under Save As Type, choose the file format. 

3 Specify the name of the file you want to create. 

4 Click Save. 
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Command line SAVEAS 

TIP You can also export drawing files to various file formats.  

Reduce the Time Required to Save a Drawing File 

In order to reduce the time of saving a drawing file, you can specify the incremental save 

percentage on the Open and Save tap of Options dialog box or from the ISAVEPERCENT 

system variable. 

The incremental save updates only the portions of the saved drawing file you changed. 

Drawing files will contain a percentage of potentially wasted space when you use 

incremental saves. This percentage increases after each incremental save until it reaches 

the specified maximum value, and then a full save is perform. 

When the ISAVEPERCENT system variable is set to 0, all saves are full saves. This 

option required more time to save a drawing file but can reduce the size of drawing files. It 

is recommend you perform a full save before transmitting or archiving a drawing. 

3.4. Error Report 

An error report module will intercept any unhandled exception generated by ZWCAD, 

build a complete debug report, and optionally send a crash report. 

Sending error report may help assess the stability of ZWCAD software while working in 

user environment, and improve the quality of our product. When errors are encountered in 

the procedure of some programs, a dialog box pops up for the user to record the cause of 

the error and send error report automatically created by the software to the assigned 

email address so as to help us diagnose the cause of the error and improve our software. 

Once the software encounters exceptional shutdown, a folder named BugReport will be 

automatically generated under the catalog C:\Documents and Settings\User 

Account\Application Data\CrashReport, in which all of the compressed packages 

generated for the exceptional situations are contained, with  *.TXT̆*.DMP as well as 

error drawing files included in each package. Here TXT and DMP files share the same 

name with the compressed package automatically generated. 

Describe Error Contents 

When errors occur in the program, a dialog box prompts ñZWCAD.EXE has encountered a 

problem and needs to close, we are sorry for the inconveniencesò for the user to input 

descriptions of the problem in the text window showing "Describe what you were doing 

when the error occurred", whereas it is an optional requirement. 

View Contents of Error Report Files 

Generally, the software generates three error reporting files, individually named as *.TXT, 

*.DMP and the crashed drawing file itself. In this error report dialog box, you can see the 

contents of error reports by clicking on ñClick hereò links following the prompts ñTo see 

what this report containsò. You can optionally select a file in the ñError Report Contentsò 

dialog box, or double click a file to view its contents.  

Send Error Report 

Clicks on ñSend Error Reportò button on the Error Reporting dialog box, then you can send 

the information of assigned error reports to CrashReport@ZWCAD.com as well as its 
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problem descriptions.  

If the network isn't connecting, a prompt box pops up telling you that ñThe error report 

wasn't sent, please send the file to CrashReport@ZWCAD.comò. From this prompt box, 

you can see the name of error report file together its saving path. 

Don't send 

Additionally, user can choose not to send error report. 
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4. Control the Drawing Views 
 

 

4.1. Redrawing and regenerating a drawing 

As you work on a drawing, visual elements may remain after the completion of a 

command.You can remove these elements by refreshing, or redrawing, the display. 

To redraw (refresh) the current window display 

Choose View > Redraw. 

Command line REDRAW 

Information about drawing entities is stored in a database as floating point values, 

ensuring a high level of precision. Sometimes a drawing must be recalculated, or 

regenerated, from the floating point database to convert those values to the appropriate 

screen coordinates. This occurs automatically. You can also manually initiate a 

regeneration. When the drawing is regenerated, it is also redrawn. 

To regenerate the current window, type regen in the command line. If more than one 

window is displayed, type regenall to regenerate all the windows. 

4.2. Magnify a View (Zoom) 

You can use ZOOM command to zoom in or zoom out the drawing view to meet your need. 

ZOOM does not change the absolute size of objects in the drawing; it changes only the 

magnification of the view.  

With this zooming feature, you can change the magnification of your drawing at any time. 

The cursor changes to a magnifying glass when a zoom tool is active. Zoom out to reduce 

the magnification so you can see more of the drawing, or zoom in to increase the 

magnification so you can see a portion of the drawing in greater detail.  

NOTE If you are working in a layout viewport and cannot zoom, the layout viewport may 

be locked. The scale and view do not change in model space while panning or zooming in 

a locked layout viewport. 

Zooming in and out 

One of the easiest ways to change the magnification of the drawing is to zoom in or out by 

a preset increment. On the Zoom toolbar, the Zoom In tool doubles the current 

magnification of the drawing. The Zoom Out tool reduces the magnification of the drawing 

by half. The portion of the drawing located at the center of the current viewport remains 

centered on the screen as you zoom in and out. 

 

ms-its:ZWCAD_ICR.chm::/ZOOM.htm
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Zooming methods 

To zoom, you can use any of the following methods: 

To define the portion of the drawing to zoom, create a window. 

To zoom in real time, press Ctrl +hold and drag the left mouse button, or use the 

Real-Time Zoom tool ( ) on the standard toolbar. 

If you have a mouse with a wheel, rotate the wheel to zoom in and out. 

Zoom to Magnify a Specified Rectangular Area 

You can specify a rectangular area defined by two corners to display the objects within 

that area as large as possibly. 

The lower-left corner of the specified area becomes the lower-left corner of the new view. 

 
To zoom in to an area using a window 

1 Choose View > Zoom > Window. 

2 Select one corner of the window around the area you want to magnify. 

3 Specify the opposite corner of the window around the area you want to magnify. 

Standard toolbar  

Command line ZOOM 

 

To specify a rectangular window around the            Results 

 area you want to magnify, select first one corner 

(A), and then select the opposite corner (B). 

Zoom in Real Time 

With the Realtime option, you zoom dynamically by moving your pointing device up or 

down. By right-clicking, you can display a shortcut menu with additional viewing options.  

To zoom in real time 

1Choose View > Zoom > Realtime. 

2 Hold the Ctrl and the left mouse button, then drag the cursor. 

3 To zoom in, move the cursor up the screen; to zoom out, move the cursor down the 

screen. 








































































































































































































































































































































































































































































































































































































































































